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mponent of the RightFax Connector for 
ightFax server and FileNet Capture 
 4.1. Capture Professional is then 
ents from the RightFax server to the 
et product suite supported by your 

ional.

received by the RightFax server can be 
 or per-user basis. Once the Connector 
and configured, fax documents from one 
ill be automatically imported into your 

ector module
nsists of these components:

or for FileNet P8  This is the software 
rver to communicate with each of the 
nd the FileNet P8 server. This connector 
 server.

t Connector (EDC)  This is a service 
erver during the server installation. The 
ctor monitors RightFax for files to store 
 then coordinates the activities of the 
ectors as fax documents are passed 
Chapte

er 1

alling the RightFax Connector for FileNet P8

iew of the RightFax Connector for 
t P8
he RightFax Connector for FileNet P8 is a suite of processors and 
onnectors that archives both sent and received fax documents 
rom your RightFax server into a FileNet data repository. With the 
ightFax Connector for FileNet P8 you can:

Send documents from your FileNet data repositories as faxes via 
the RightFax server. 

Automatically or manually index fax documents received via the 
RightFax server.

Use capture paths to commit RightFax documents to a document 
data repository.
Use Fax Entry to commit RightFax documents to a document 
repository.

Print archived RightFax documents based on document data, 
such as the RightFax user ID, billing information, or job type 
(received, sent, or print job).

he RightFax Connector for FileNet P8 consists of two modules: 
he Connector module and the Outbound module (described in 
hapter 3, “Using the Outbound Module to Send FileNet 
ocuments as Faxes”. You can install both of these modules or 
ither module separately, depending on the needs of your 
rganization.

Understanding the Con
The Connector module co
FileNet P8 connects the R
Professional version 4.0 or
configured to move docum
data repository of any FileN
version of Capture Profess

Documents sent from and 
archived on a system-wide
module has been installed 
or more RightFax servers w
FileNet data repository.

Components of the Conn
The Connector module co

The RightFax Connect
that allows the RightFax se
connector’s components a
is installed on the RightFax

The External Documen
installed on the RightFax s
External Document Conne
in the FileNet repository. It
other processors and conn
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am illustrates the progress of a document as it 
ghtFax server into a FileNet data repository.

 Documents in a FileNet data repository

iew
he RightFax Connector for FileNet P8, make 
tFax and FileNet P8 systems meet the following 

r version 8.7 or higher is installed and operating.

s/RightFax folder and all subfolders must be 
 access to the Capture Professional workstation 
e incoming fax documents.

Professional version 4.0 or 4.1 must be installed 
and must have all available patches applied.
into the repository. This chapter includes information on installing 
and configuring the External Document Connector. For a more 
complete description of the External Document Connector, see 
Appendix A, “Understanding the External Document Connector”.

The RightFax Connector for Capture Professional  This is 
the software that allows the RightFax External Document 
Connector to pass files into Capture Professional or to Fax Entry, 
which moves them into the FileNet repository. The RightFax 
Connector for Capture Professional is installed on a Capture 
Professional workstation and emulates an intelligent scanner. It 
bundles the RightFax documents into batches and delivers them to 
Capture Professional or it holds them for retrieval by Fax Entry.

How documents are moved into the FileNet repository
Fax documents on the RightFax server are picked up by the 
External Document Connector and passed through the RightFax 
Convert processor, the RightFax Connector for Capture 
Professional, and the RightFax Print processor.

� The Convert processor converts the document files to the 
required single-page TIFF format.

� The RightFax Connector for Capture Professional organizes the 
fax documents into batches (including the fax images and 
document data that can be used for indexing purposes) and 
imports them into Capture Professional.

� The Print processor optionally prints the fax documents. Capture 
Professional then moves the fax documents into the FileNet data 
repository via capture paths or via Fax Entry.

The following diagr
is routed from a Ri

Figure 1.1  Archiving

Installation Overv
Before you install t
sure that your Righ
requirements:

� A RightFax serve

� The Program File
shared, providing
which will manag

� FileNet Capture 
on your network 
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d to restart the computer, click Yes.

ing the External Document 

nnector (EDC) is a RightFax module 
unication between the RightFax server 
nstall the Connector for FileNet P8 on 
ust activate the External Document 
 server and set some configuration 
 provide only the information necessary 

he External Document Connector. For a 
 of the External Document Connector, 
nding the External Document 

cument Connector
nnector is installed as an optional 
x server. If you did not select the External 
on when you ran the RightFax server 
lled now.

ocument Connector

rams from Windows Control Panel, 
uct Suite, and then click Change.

g screen. This opens a list of installation 
and click Next.

 screen, expand the RightFax Server 
ternal Document Connector (EDC) for 

n Wizard according to the instructions 
ion Guide.

d to reboot the computer, click Yes.
Chapte

nce you have met these requirements, complete the following 
teps to install and configure the RightFax Connector for 
ileNet P8:

. Install the Connector on the RightFax server (page 7).

. Activate and configure the External Document Connector on the 
RightFax server (page 8).

. Install the RightFax Connector for Capture Professional on the 
Capture Professional workstation (page 12).

. Optionally install and Configure the Outbound Module 
(page 25).

ling the Connector on the RightFax Server
he RightFax Connector for FileNet P8 is provided on a CD 
eparate from the RightFax installation CD. Before you install the 
onnector on the RightFax server, make sure that RightFax server 
ersion 8.7 or higher is fully installed and running. For information 
n installing or upgrading your RightFax server, refer to the 
ightFax Installation Guide.

o install the connector on the RightFax server

. Log on to the RightFax server and insert the Connector for 
FileNet P8 installation CD. If AutoRun is enabled, a menu of 
install options appears. If AutoRun is not enabled, browse the 
CD and run AutoRun.exe.

. In the menu of install options, select Install the Connector on 
the RightFax Server. The Connector for FileNet P8 install 
wizard opens.

. Click Next at the opening screen to view the RightFax license 
agreement. You must accept the license agreement in order to 
continue the installation. Click Next.

. Click Install. When the installation is complete, click Finish.

5. When you are prompte

Activating and Configur
Connector

The External Document Co
that allows two-way comm
and FileNet P8. After you i
the RightFax server, you m
Connector on the RightFax
options. These instructions
to activate and configure t
more complete description
see Appendix A, “Understa
Connector”.

Installing the External Do
The External Document Co
component on the RightFa
Document Connector opti
installation, it must be insta

To install the External D

1. Run Add/Remove Prog
highlight RightFax Prod

2. Click Next at the openin
options. Select Modify 

3. On the Setup Features
category and select Ex
install. Click Next.

4. Complete the Installatio
in the RightFax installat

5. When you are prompte
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 Document Connector, click the Enabled 

d Receives boxes, specify the types of fax 
 want to archive with FileNet P8. You can archive 
that have been both transmitted via the RightFax 
ds option) and received into the RightFax server 
ption).

ese fax documents will not be archived.

ly specific RightFax users that have this feature 
eir user records will have their fax documents 
scribed in the next section).

eceives. All fax documents of this type will be 

cuments on a per-user basis

er in either the Sends or Receives boxes in the 
ion dialog box (described in the previous 

 configure each individual RightFax user for 
mage Services.

Fax Manager.

der the appropriate RightFax server in the list of 
e left pane.
Activating the External Document Connector in the 
RightFax Server Configuration

As soon as it is activated on the RightFax server, the External 
Document Connector will begin queueing fax documents for 
delivery to the RightFax Connector for FileNet P8. These fax 
documents will remain queued but unprocessed until you complete 
the installation and configuration of all of the connector 
components.

To activate the External Document Connector

1. On the RightFax server, run Enterprise Fax Manager.

2. In the list of RightFax servers in the left pane, select the 
RightFax server on which the Connector for FileNet P8 software 
is installed.

3. In the list of services in the bottom pane, double-click RightFax 
Server Module. This opens the Server Configuration dialog 
box. Click the Advanced tab.

Figure 1.2  Activating the External Document Connector

4. Under External
check box.

5. In the Sends an
documents you
fax documents 
server (the Sen
(the Receives o

� Disabled. Th

� By User. On
enabled in th
archived (de

� All Sends/R
archived.

6. Click OK.

To archive fax do

If you select By Us
Server Configurat
section), you must
access to FileNet I

1. Run Enterprise 

2. Click Users un
fax servers in th
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 Document Connector
nnector does not require any 
rocess and archive users’ fax 
ax server. However, some configuration 

utomatically print archived fax 
m filters that limit the range of 
d or printed. In addition, the External 
you generate sample fax jobs that can 
eNet P8 to index fax documents based 

ent data (such as user name or billing 

r FileNet P8 configuration in the External 
s a FlowPoint called Convert_To_TIFF. The 

int lets you set the format of the file that will 
fessional or Fax Entry. By default this is set 
st not change this setting. If the External 
ot convert the files to single-page TIFF 

 and Fax Entry will be unable to retrieve the 

rnal Document Connector, see 
g the External Document Connector”. 
ption in the External Document 
n in the title bar and then click the 

al Document Connector to print 

nel, run the RightFax EDC program.

opens a list of modules that have been 
l Document Connector.

nagon/P8 option in the list. This 
oints for FileNet P8 job processing.

ges. A list of configuration options 
.

Chapte

. Double-click the user to edit. The User Edit dialog box opens. 
Click the Permissions tab.

Figure 1.3  Selecting the EDC Processing Options

. Select the EDC Process Received Faxes check box if you 
want this user’s received fax documents to be archived. Select 
the EDC Process Sent Faxes check box if you want this user’s 
sent fax documents to be archived. RightFax users do not have 
an option to override these settings in the RightFax client 
applications.

. Click OK and repeat for each RightFax user whose fax 
documents should be archived.

Configuring the External
The External Document Co
configuration to correctly p
documents from the RightF
is required if you want to a
documents or create custo
documents that are archive
Document Connector lets 
be used for configuring Fil
on RightFax-specific docum
codes).

Warning  The Connector fo
Document Connector include
configuration for this FlowPo
be picked up by Capture Pro
to Single-page TIFF. You mu
Document Connector does n
format, Capture Professional
file.

For an overview of the Exte
Appendix A, “Understandin
For a description of each o
Connector, click the [?] ico
option you want defined.

To configure the Extern
archived faxes

1. In Windows Control Pa

2. Click Data Flows. This 
activated in the Externa

3. Expand the FileNet_Pa
displays all of the FlowP

4. Select FP#3 Print_Ima
opens in the right pane
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 Filter. This opens the FlowPoint Filter 
 box.

lowPoint Filter Options dialog box

rocess all jobs option is selected and no filters 
ll documents will be processed.

r, specifying either which jobs should be 
ed or explicitly excluded, select Process only 
ied by the filters.

pecify filter keywords.

 process only the jobs that meet your filter 
ify filter data in the Include box.
 process most jobs, but specifically exclude 

et your filter criteria specify filter data in the 
.

xclude box will be evaluated by the connector 
verride criteria in the Include box.

nd data are not case-sensitive. To enter a string 
d data, type a semicolon between each keyword 
he semicolon acts as a logical OR statement, 

hat meet any one of your keyword criteria will be 
5. Click Configure FlowPoint. This opens the Print FlowPoint 
Settings dialog box.

Figure 1.4  The Print FlowPoint Settings dialog box

6. Select a printer and then specify which fax document 
components to print.

7. Click OK.

To create filters that limit the range of archived and printed 
faxes

1. In Windows Control Panel, run the RightFax EDC program.

2. Click Data Flows. This opens a list of modules that have been 
activated in the External Document Connector.

3. Expand the FileNet_Panagon/P8 option in the list. This 
displays all of the FlowPoints for FileNet P8 job processing.

4. Select FP#1 Convert_To_TIFF to filter the faxes that will be 
archived, or click FP#3 Print_Images to filter the faxes that will 
be automatically printed. The remaining filter instructions apply 
to creating filters for both processes. When you select one of 
these FlowPoints, a list of configuration options opens in the 
right pane.

5. Click Configure
Options dialog

Figure 1.5  The F

By default, the P
are set up, so a

6. To create a filte
explicitly includ
the jobs specif

7. Under Filters, s

� If you want to
criteria, spec

� If you want to
jobs that me
Exclude box

Criteria in the E
first, and it will o

The keywords a
of keywords an
and value pair. T
so documents t
filtered.
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al;UserID=sales;UserID=marketing

ted the FlowPoint Filter Options dialog 

 jobs for configuring indexing

nel, run the RightFax EDC program.

ens a list of modules that have been 
l Document Connector.

r and click Edit. This opens the 
ce dialog box.

ote caller 
ber ID (CSID) of 
htFax document.

remoteID=5550022

que ID of the 
nt, assigned by 

htFax server.

uniqueID=
SAR3D64FD3F1D16

htFax user ID of 
on who sent the 
nt.

userid=sales

ords used for filtering (Continued)

tion Example
Chapte

To filter documents, the data values for the keyword must match 
the RightFax document data. For example, to import all 
documents that include the user ID “sales,” documents with the 
user ID “sales23” will not be imported.

You can create filters based on any keyword in the job file. You 
can view many of these keywords by opening the sample sent 
and received fax job files you create with the External Document 
Connector. The steps to generate these sample fax jobs are on 
page 11. The sample job files are saved in the 
Program Files\RightFax\EDC\Processors\FileNet folder and 
can be viewed with any text editor. These files are numbered 
consecutively and have the extension .job. The following table 
lists some of the keywords most commonly used for creating 
filters. Example

BillingInfo1=internation

8. When you have comple
box, click OK.

To generate sample fax

1. In Windows Control Pa

2. Click Sources. This op
activated in the Externa

3. Select RightFax Serve
RightFax Server Sour

Table 1a  Common keywords used for filtering

Keyword Description Example

BillingInfo1

BillingInfo2

Billing information from 
the RightFax document.

billinginfo1=marketing

GenericFlag1

GenericFlag2

If an application in your 
enterprise is customized 
to work with the 
RightFax API, this 
keyword refers to the 
API constants 
FAXFLAG_GENERIC1 
and 
FAXFLAG_GENERIC2.

The value for the 
keyword is true or false.

genericflag1=true

genericflag1=false

JobType Job types are:

� SendJob
� ReceiveJob
� PrintJob

jobtype=sendjob

RemoteCSID

RemoteID

The rem
subscri
the Rig

UniqueID The uni
docume
the Rig

UserID The Rig
the pers
docume

Table 1a  Common keyw

Keyword Descrip
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I
P

htFax Connector on a Capture 
rkStation

ecommends that the RightFax Connector for 
l not be installed on the RightFax server, even if the 
Capture Professional installed.

apture Professional workstation.

he shared Program Files\RightFax folder on the 
.

ector for FileNet P8 installation CD. If AutoRun 
enu of install options appears. If AutoRun is not 
e the CD and run AutoRun.exe.

nstall options, select Install the RightFax 
Capture Professional on a Capture 
orkstation. The Connector for FileNet P8 install 

e opening screen to view the RightFax license 
 must accept the license agreement in order to 
tallation. Click Next.

hen the installation is complete, click Finish.

Fax.ocx Capture Professional component

apture Professional workstation where you 
htFax Connector for Capture Professional, open 
apture Manager.

to the Components list. The Add Capture 
log box opens.

 RightFax folder under the Capture\Programs 
t the component file RightFax.ocx.

close the FileNet P8 Capture Manager.
4. Click the RightFax Options tab.

Figure 1.6  The RightFax Options tab

5. Click both the Receive Fax and Send Fax buttons. Sample fax 
jobs will be generated for use in configuring indexing on the 
FileNet P8 server.

6. Click OK and then close the External Document Connector 
program.

nstalling the RightFax Connector on a Capture 
rofessional WorkStation

After the External Document Connector has been activated and 
configured as necessary, you must install the RightFax Connector 
for Capture Professional. The RightFax connector supports 
Capture Professional version 4.0 and 4.1.

The RightFax Connector for Capture Professional organizes the fax 
documents into batches (including the fax images and document 
data that can be used for indexing purposes) and imports them into 
Capture Professional.

To install the Rig
Professional Wo

Caution  Captaris r
Capture Professiona
RightFax server has 

1. Log on to the C

2. Map a drive to t
RightFax server

3. Insert the Conn
is enabled, a m
enabled, brows

4. In the menu of i
Connector for 
Professional W
wizard opens.

5. Click Next at th
agreement. You
continue the ins

6. Click Install. W

To add the Right

1. On the same C
installed the Rig
the FileNet P8 C

2. Click Add next 
Component dia

3. Navigate to the
folder and selec

4. Click Close to 
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ptions tab.

apture Professional Processing Mode

he RightFax Connector for Capture 
 three types of batches for delivery to 

tch Breaks. This option creates a batch 
cessing mode requires assembly before 
assed to the repository.
cument Breaks. This option creates 
ts under the batch in which they were 

his processing mode requires assembly 
an be passed to the repository.
is option creates multiple fax 

e batch in which they were originally 
ot require assembly before documents 
 repository.

ment/Page processing mode is 
on system resources, this option should only 
 to use the other two processing modes.
Chapte

figuring the RightFax Connector for Capture 
fessional
ou have the following options for customizing the RightFax 
onnector for Capture Professional:

“Specifying the volume of documents to process” (page 13).
“Defining which documents to import based on document data 
filters” (page 14).

cifying the volume of documents to process

apture Professional requires that all documents be archived in the 
orm of batches. Batches are distinct groups of documents and 
ocument data that have been formatted for Capture Professional. 
ou can specify the format of batches to process and number of 
ightFax documents in each batch.

o configure batches of documents

. In Capture Professional, select your settings collection for 
RightFax fax documents (to set the default configuration for all 
batches) or select an individual batch (to configure that batch 
only).

. Select Tools > Configure > RightFax Fax. The RightFax 
Connector for Panagon Capture Professional Properties 
dialog box opens.

3. Click the Document O

Figure 1.7  Selecting a C

Processing Mode  T
Professional can create
Capture Professional:

� Pages Only with Ba
for each fax. This pro
documents can be p

� Pages Only with Do
multiple fax documen
originally received. T
before documents c

� Document/Page. Th
documents under th
received and does n
can be passed to the

Note  Because the Docu
exceptionally demanding 
be used if you are unable
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a for documents to import

essional, select your settings collection for 
cuments (to set the default configuration for all 
ct an individual batch (to configure that batch 

 Configure > RightFax Fax. The RightFax 
Panagon Capture Professional Properties 
s.

g the Connector Properties

ector Options tab.

ments that should be imported from this 
d on RightFax document characteristics, select 

 Select this option if all documents should be 
Maximum Faxes  This is the maximum number of fax 
documents that will be pulled from the job folder at one time. 
Enter a number from 1 to 20.

Tip  If the batch already contains faxes, the number of faxes you enter 
in this box will be added to the existing faxes in the batch.

Maximum Pages  This is the maximum number of individual 
fax pages that will be pulled from the job folder at one time. 
Enter a number from 1 to 999.

4. When you have completed the RightFax Connector for 
Panagon Capture Professional Properties dialog box, click 
Apply, and then click OK.

Defining which documents to import based on document 
data filters

The RightFax Connector for Capture Professional organizes 
RightFax documents into batches and imports them into Capture 
Professional. You can create a filter that limits the documents to 
import based on RightFax document data, such as a RightFax user 
ID or billing code.

To specify criteri

1. In Capture Prof
RightFax fax do
batches) or sele
only).

2. Select Tools >
Connector for 
dialog box open

Figure 1.8  Settin

3. Click the Conn

4. To specify docu
connector base
a filter mode.

� All Filtering.
imported.
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ilter keywords.

s only the jobs that meet your filter 
data in the Include Filter box.
s most jobs, but specifically exclude 
ilter criteria specify filter data in the 

Filter box will be evaluated by the 
ill override criteria in the Include Filter 

 are not case-sensitive. To enter a string 
ype a semicolon between each keyword 
icolon acts as a logical OR statement, 
t any one of your keyword criteria will be 
Chapte

� Cooperative Filtering. Select this option to allow multiple 
capture paths to monitor one job directory for documents. 
With cooperative filtering, jobs remain stored in the job 
directory until they are imported by one of the RightFax 
Connectors for Capture Professional. Criteria for importing 
documents are based on keywords you specify in the 
Include Filter and Exclude Filter boxes.

Cooperative filtering is used if you want to use different 
filters. Unlike Exclusive filtering, Cooperative filtering will not 
delete a job that doesn't meet its filter criteria. The job stays 
in the job directory until it is picked up by the appropriate 
filter.

If you select Cooperative filtering, Captaris recommends 
creating a catch-all filter that periodically picks up any jobs 
that do not meet other filter criteria. For example, if you have 
one filter configured as “UserID=TechSupport” and another 
configured as “UserID=Sales,” there should be a third 
catch-all filter that has “UserID=TechSupport;UserID=Sales” 
for it's Exclude settings and a blank Include setting. This 
filter will pick up any jobs that don't happen to be for 
TechSupport or Sales so they don't remain unprocessed in 
the job directory indefinitely. 

� Exclusive Filtering. Select this option if a single connector 
will evaluate and import files from this job directory. Criteria 
for importing documents are based on keywords you specify 
in the Include Filter and Exclude Filter boxes. The 
connector evaluates the filter criteria, and it imports the 
documents that meet the criteria. If the filter criteria are not 
met by the document, the connector passes the document to 
the RightFax Print processor.

You should select Exclusive filtering if you want to process 
only certain jobs and throw away anything that doesn't meet 
the filter criteria. You may have more than one workstation 
running in this mode only if they have identical filters.

5. Under Filters, specify f

� If you want to proces
criteria, specify filter 

� If you want to proces
jobs that meet your f
Exclude Filter box.

Criteria in the Exclude 
connector first, and it w
box.

The keywords and data
of keywords and data, t
and value pair. The sem
so documents that mee
filtered.
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e Capture Professional workstations and you 
 Sales faxes only on one workstation, Marketing 
other station, and all other faxes on the third 
 filters should be set up as follows:

orkstation would have UserID=Sales in the 
rs box. The Exclude Filters box is left empty.

g workstation would have UserID=Marketing in 
Filters box. The Exclude Filters box is left 

ch-all workstation would have 
s;UserID=Marketing in the Exclude Filters box. 
Filters box is left empty.

 completed the RightFax Connector for 
ure Professional Properties dialog box, click 
 click OK.

� � �

The remote caller 
subscriber ID (CSID) of 
the RightFax document.

remoteID=5550022

The unique ID of the 
document, assigned by 
the RightFax server.

uniqueID=
SAR3D64FD3F1D16

The RightFax user ID of 
the person who sent the 
document.

userid=sales

on keywords used for filtering (Continued)

Description Example
To filter documents, the data values for the keyword must match 
the RightFax document data. For example, to import all 
documents that include the user ID “sales,” documents with the 
user ID “sales23” will not be imported.

You can create filters based on any keyword in the job file. You 
can view many of these keywords by opening the sample sent 
and received fax job files you create with the External Document 
Connector. The steps to generate these sample fax jobs are on 
page 11. The sample job files are saved in the 
Program Files\RightFax\EDC\Processors\FileNet folder and 
can be viewed with any text editor. These files are numbered 
consecutively and have the extension .job. The following table 
lists some of the keywords most commonly used for creating 
filters. Example

If there are thre
want to capture
faxes only on an
workstation, the

� The Sales w
Include Filte

� The Marketin
the Include 
empty.

� The third cat
UserID=Sale
The Include 

6. When you have
Panagon Capt
Apply, and then

Table 1b  Common keywords used for filtering

Keyword Description Example

BillingInfo1

BillingInfo2

Billing information from 
the RightFax document.

billinginfo1=marketing

GenericFlag1

GenericFlag2

If an application in your 
enterprise is customized 
to work with the 
RightFax API, this 
keyword refers to the 
API constants 
FAXFLAG_GENERIC1 
and 
FAXFLAG_GENERIC2.

The value for the 
keyword is true or false.

genericflag1=true

genericflag1=false

JobType Job types are:

� SendJob
� ReceiveJob
� PrintJob

jobtype=sendjob

RemoteCSID

RemoteID

UniqueID

UserID

Table 1b  Comm

Keyword
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 Professional Fax Entry 

r FileNet P8 supports the Capture 
ure. With a few exceptions, the 
 the connector to work with Fax Entry 
FileNet product. The instructions are 

pes of data to a repository and/or to a 
irectory. Each type of data is described 

sed by Fax Entry

cription

Entry accepts faxes from a remote 
tion through a fax server.

Entry processes all files it finds in a 
ified directory.

Entry creates a journal log, recording 
ts that occur as inbound faxes or 
rted files are processed.
Chapter 2 Configuring Capture Professiona

er 2

figuring Capture Professional to Commit Documen
ileNet Data Repositories

rted FileNet Product Suites
ileNet P8 is comprised of several unique product suites that store 
nd manage your documents and data. The RightFax Connector for 
ileNet P8 can be used to store RightFax documents in the data 
epositories of any FileNet product suite supported by your version 
f Capture Professional.

or example, Capture Professional version 4.0 supports these 
roduct suites:

Image Services

Content Services

apture Professional version 4.1 supports these additional product 
uites:

Image Manager Suite
Content Manager Suite

Web Content Manager Suite

Business Process Manager Suite

hese are the content management systems that let you receive 
axes from the RightFax server directly into your FileNet document 
epository.

Support for the Capture
Feature

The RightFax Connector fo
Professional Fax Entry feat
instructions for configuring
the same as those for the 
provided in this chapter.

Fax Entry commits three ty
specific local or network d
in the following table.

Table 2a  Data That Is Proces

Data Des

Inbound faxes Fax 
loca

Imported files Fax 
spec

Journal entries 
created by Fax Entry

Fax 
even
impo
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C
i

ing capture path components from the 
st into the list under the name of your new 
 the exact order they are listed here:

x

bly component is unnecessary if you select 
as your processing mode (see “Configuring the 
tor for Capture Professional” on page 13).

inished moving the capture path components, 
 opens the Capture Path Layout window (a type 
strating the data flow through your capture 

imize option.

 added components are laid out in this order:

Assembly � Index � Commit � End

 Fax are the only required components of a path for 
nts. This capture path commits all available RightFax 
 data repository.

p to add a new Save/Stop object between the 
d objects.

ly object, locate the box labeled Empty. 
sor over this box until the cursor changes to a 
rag the box from the Assembly object to the 

ect.

t. to add a new Save/Cont. object between the 
 End objects.
reating a Capture Path to Move Fax Documents 
nto the Repository

Capture paths automate the process of committing documents into 
a FileNet data repository after they have been received by Capture 
Professional. If you are using Fax Entry to commit fax documents to 
the FileNet data repository, capture paths are not required.

The instructions provided here create a capture path that commits 
all available RightFax documents to a FileNet data repository. Other 
capture path configurations can be created to meet the needs of 
your organization.

To create a capture path for RightFax fax documents

In this procedure you must specify a repository to which the 
capture path will commit fax documents. This can be either a new 
or an existing repository. If you want to use a new repository, create 
the repository before beginning this procedure. For information on 
creating a new repository, refer to the documentation for your 
FileNet product suite.

1. Run Capture Professional and select the repository in which you 
will be storing fax documents.

2. Select File > New > Capture Path. The FileNet P8 Capture 
Path wizard opens. Click Next on the introductory screen.

3. Select the repository where you want inbound fax documents to 
be stored. Click Next.

4. In the Name box under Define New Capture Path, type a name 
for the new capture path. Leave the remaining options 
unchanged and click Next.

5. Move the follow
Components li
capture path in

� RightFax Fa
� Assembly
� Index
� Commit

Note  The Assem
Page/Document 
RightFax Connec

6. When you are f
click Next. This
of flow chart illu
path).

7. Check the Max

8. Ensure that the

Begin � Fax � 

Note  Begin and
RightFax docume
documents to the

9. Click Save/Sto
Commit and En

10.On the Assemb
Position the cur
double-arrow. D
Save/Stop obj

11.Click Save/Con
Save/Stop and
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Config
the Ri

T
m
f
C
m
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s collection

onfigure several settings under the data 
 inbound fax documents to be stored. 
r existing repository. If you want to use a 
repository before beginning this 
 on creating a new repository, refer to 
r FileNet product suite.

nal.

iner in the repository where you want 
 to be stored, click Settings.

ttings. The FileNet P8 Capture settings 
xt on the introductory screen.

here you want inbound fax documents to 

tings Collection, in the Name box, type 
tings collection. Leave the remaining 
 click Next.

cument class for indexing (described 
cument class name and click Next.

figuration screen, select RightFax Fax 
e RightFax Connector for Capture 
s dialog box opens.

e box, enter the name for this connector 
n. You can define unique connectors for 

e Connector to work with Fax Entry, in 
Minutes box, enter the interval that Fax 
ctor for documents. Enter a number of 
Chapter 2 Configuring Capture Professiona

2.On the Save/Cont. object, locate the box labeled Empty. 
Position the cursor over this box until the cursor changes to a 
double-arrow. Drag the box from the Save/Cont. object to the 
Fax object.

The final diagram should look like this:

Figure 2.1  The Completed Capture Path Layout

3.Click Next.

4.Finally, click Finish to close the FileNet P8 Capture Path wizard.

uring Capture Professional to Work with 
ghtFax Connector
o configure the RightFax Connector for Capture Professional, you 
ust create and configure a new settings collection and template 

or RightFax documents. As described in “Installing the RightFax 
onnector on a Capture Professional WorkStation” (page 12), you 
ay have installed one or multiple capture paths and settings 
ollections on one or more Capture Professional workstations.

To create a new setting

In this procedure you will c
repository where you want
This can be either a new o
new repository, create the 
procedure. For information
the documentation for you

1. Run Capture Professio

2. Under the Config conta
inbound fax documents

3. Select File > New > Se
wizard opens. Click Ne

4. Select the repository w
be stored. Click Next.

5. Under Define new Set
a name for the new set
options unchanged and

6. If you created a new do
page 20), select the do

7. On the component con
and click Configure. Th
Professional Propertie

8. In the Connector Nam
in this settings collectio
settings collections.

9. If you are configuring th
the Polling Interval in 
Entry will poll the conne
minutes.
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sitory where you want inbound fax documents to 
 Next.

ew Settings Collection, in the Name box type a 
w template. Leave the remaining options 
 click Next.

 settings collections screen, select the name of 
lection you created in the previous steps and 

e following options:

nfiguring a template for Fax Entry, click Next to 
.

onfigured a capture path for RightFax fax 
described on page 18) select the capture path 
re Path box and click Next. 

ish to close the FileNet P8 Capture template 

ment Indexing in a FileNet 

matically index fax documents when they are 
a repository, you must specify the data fields you 
link those fields to the data that is included with 

ents. 

nstructions are specific to FileNet Image Services. If 
nnector for FileNet P8 to commit documents to a 
ifferent product suite, you may want to review these 

ly the principles for document indexing to your 
e.

so is available in Capture Professional. Refer to 
sional documentation for more information.
10.In the Job Directory box, type the path to the Panagon folder on 
the source RightFax server. Type the UNC path to a folder on 
the server or the absolute path to the folder on the local 
computer. Click Apply, and then click OK.

Note  This step is required to enable communication between the 
RightFax source server and the Capture module. There are several 
additional options in this dialog box that let you customize the 
operation of the connector. For a complete description of all of the 
options in this dialog box, see “Configuring the RightFax Connector 
for Capture Professional” on page 13.

Figure 2.2  Specifying the Path to the Panagon Folder on the Source 
RightFax Server

11.Click Next, and then click Finish to close the FileNet P8 
Capture settings wizard.

To create a new template

1. In Capture Professional, under the Config container, click 
Templates.

2. Select File > New > Template. The FileNet P8 Capture 
template wizard opens. Click Next on the introductory screen.

3. Select the repo
be stored. Click

4. Under Define n
name for the ne
unchanged and

5. On the available
the settings col
click Next.

6. Select one of th

� If you are co
skip this step

� If you have c
documents (
in the Captu

7. Finally, click Fin
wizard.

Enabling Fax Docu
Product Suite

If you want to auto
committed to a dat
want indexed and 
RightFax fax docum

Important  These i
you are using the Co
data repository in a d
instructions and app
specific product suit

Manual indexing al
the Capture Profes
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 this dialog box according to your 
ents. The document class you configure 
RightFax fax documents archived in your 
.

ate Class dialog box is completed, 
ave the settings.

e User Defined Index dialog box 

ields you created in step 7.

lds have been added, click Cancel, and 
rn to the Database Maintenance dialog 

ave the settings and then File > Exit to 
intenance dialog box.

start the Image Services server. This 
changes to take effect.

ent Data to the FileNet Index
se a sample RightFax document to map 
xing fields you set up on the Image 
x fax documents.

set up your Image Services server to 
 documents (described on page 20).
Chapter 2 Configuring Capture Professiona

o enable fax document indexing

ote  The following instructions assume that you have access to and are 
amiliar with the FileNet Image Services server. If you need further 
nformation on any of the dialog boxes or options described in this 
ection, refer to your FileNet documentation.

. On the Image Services server, run Application Executive.

. Select Applications > Database Maintenance to open the 
Database Maintenance dialog box.

. Select Families > Define/Update Family. The Define/Update 
Media Families dialog box opens.

. Complete this dialog box according to your organizational 
requirements. The family you configure here will contain a new 
document class for RightFax fax documents. You can either 
create a new family or select an existing family.

. When the Define/Update Media Families dialog box is 
completed, select File > Save to save the settings, and then 
File > Exit to return to the Database Maintenance dialog box.

. Select Indexes > Define/Update Index. The Define/Update 
Index dialog box opens.

. For each data field that you want to index, complete the entries 
in this dialog box according to your organizational requirements. 
The index fields you add here must correspond to (but do not 
need to have the same names as) the data fields that are 
included with RightFax fax documents. For a list of the RightFax 
document data fields, see Appendix B, “RightFax Document 
Data Fields”.

. When the Define/Update Index dialog box is completed, 
select File > Save to save the settings, and then File > Exit to 
return to the Database Maintenance dialog box.

. Select Classes > Define/Update Class. The Define/Update 
Class dialog box opens.

10.Complete the entries in
organizational requirem
here will be used for all 
Image Services system

11.When the Define/Upd
select File > Save to s

12.Select Index > Edit. Th
opens.

13.Add each of the index f

14.When all of the index fie
then click Close to retu
box.

15.Select File > Save to s
close the Database Ma

16.Finally, stop and then re
step is required for the 

Mapping RightFax Docum
In this procedure you will u
available data fields to inde
Services server for RightFa

This is required only if you 
index archived RightFax fax
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apture path to automate moving fax documents 
ry (described on page 18), select the Process 

ing initial values above check box.

g the Field Priority

tab.

index field in the list and click Configure. The 
s dialog box opens.

tructions provide information on options required to 
of RightFax document data only. For more 
e options on each tab of this dialog box, refer to your 
tation.

Masks tab.
To map RightFax data to your index

1. If you did have not already followed the instructions for 
generating sample faxes from the External Document 
Connector (described in the section entitled “To generate 
sample fax jobs for configuring indexing” on page 11), follow 
those steps now. This creates sample fax documents that act as 
templates when setting up fields for indexing.

2. On the Capture Professional workstation, run Capture 
Professional.

3. Select the new setting you created in the previous step and 
select Tools > Start > RightFax Fax.

Note  When you added the RightFax component, a Fax button was 
added to the Capture Professional toolbar. Clicking this button is the 
same as selecting Tools > Start > RightFax Fax.

4. Click the settings collection you created for RightFax fax 
documents and select Tools > Configure > Index. The 
Panagon Capture Index Control Properties dialog box opens.

5. On the General tab, click Set fields by priority, and then select 
Auto Index, Default, Stored in the list.

6. If you set up a c
into the reposito
documents us

Figure 2.3  Settin

7. Click the Field 

8. Select the first 
Field Propertie

Note  These ins
enable indexing 
information on th
FileNet documen

9. Click the Input 
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 steps for each index field listed in the 
x Control Properties dialog box.

n the Panagon Capture Index Control 
een configured, click Apply, and then 

ialog box.

� �
Chapter 2 Configuring Capture Professiona

0.In the Default field value box, type a value that will populate this 
index field if the data is unavailable in the RightFax fax 
document.

Figure 2.4  Setting the Default Field Value

1.Click the Auto-Index tab.

2.In the Source Group box, select FAX.

3.In the Source Name box, select the field from the RightFax 
document that corresponds to the index field you are mapping.

4.Click Append Auto Index String. An index string appears in the 
Auto Index string box.

Figure 2.5  Creating the Auto-Index String

15.Click OK. Repeat these
Panagon Capture Inde

16.When each index field i
Properties dialog has b
click OK to close the d

� 
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ing the Outbound Module
x Outbound Module from any previous 
stall the old version using Add/Remove 
trol Panel. When you uninstall the 
e module settings and configurations 
ecommends that you make a note of the 
ll it.

ound module of the RightFax Connector 
hat your RightFax and FileNet systems 
ents:

t be version 8.7 or higher.
or 4.3 must be installed and configured 
on your network. 

 Outbound module, complete the 

bound module on the FileNet Print 
ge 26).

nter (described on page 26).

inistrator (described on page 29).

ger (described on page 30).
Chapter 3 Using the Ou

er 3

g the Outbound Module to Send FileNet Documen

he RightFax Connector for FileNet P8 can be used to send 
mages from a FileNet data repository as faxes via the RightFax 
erver. This component of the RightFax Connector for FileNet P8 is 
alled the “Outbound module,” because documents are transmitted 
s faxes from your data repository.

ith the Outbound module, the RightFax server is configured as a 
eneric fax printer on a FileNet Print server. When a user prints to 
his RightFax printer from the IDM desktop client, the user is 
rompted for fax addressing information (fax number, recipient 
ame, etc.), and then the image and addressing information are 
ent to the RightFax server for transmission.

he following diagram illustrates the process of faxing a document 
rom a FileNet product Suite via a RightFax server.

igure 3.1  Faxing a Document Via the RightFax Server

Installing and Configur
To upgrade to the RightFa
version, you must first unin
Programs in Windows Con
Outbound module, all of th
will be removed. Captaris r
settings before you uninsta

Before you install the Outb
for FileNet P8, make sure t
meet the following requirem

� The RightFax server mus
� FileNet Print version 4.2 

on a FileNet Print server 

To install and configure the
following steps:

1. Install the RightFax Out
server (described on pa

2. Create the RightFax pri

3. Start FileNet Print Adm

4. Start FileNet Fax Mana
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C

Fax printer on the FileNet product suite 

nstructions are specific to FileNet Image Services. If 
ightFax printer in a different product suite, you may 
 instructions and apply the principles for creating the 
our specific product suite.

ervices server, run the FileNet P8 Configuration 
ing Start > Programs > FileNET IMS 
> Configuration Editor. The Open 
Database dialog box opens.

ase and domain name of the Image Services 
ure. Verify that the Read-only option is not 
lick OK. This opens the FileNet IMS System 
ditor.

dures tab.

rinter, and then click Run. The Add a Printer 
s.

/Fax 3.0 as the printer type, and then click 

r the new RightFax printer, and click Next.

ude spaces in the name of the printer. Substitute 
 other characters for spaces in the printer name 
ightFax_Fax_Printer).

ress of the FileNet Print server, and then click 

r sizes to support, and then click Next.

solutions to support, and then click Next.

ant to set the printer as the default printer, and 
.

the message “Edit procedure completed 
ick OK.
nstalling the Outbound Module on the FileNet 
rint Server

This step installs the Outbound module on your FileNet Print 
server. If you have more than one FileNet Print server on your 
network, you must follow these installation instructions on each 
server that you want to support faxing via RightFax.

To install the Outbound module

1. On the FileNet Print server, insert the Connector for FileNet P8 
CD. If AutoRun is enabled, a menu of install options appears. If 
AutoRun is not enabled, browse the CD and run AutoRun.exe.

2. In the menu of install options, select the option Install the 
Outbound Module on a Panagon Print server.

3. Follow the instructions on the screen.

4. When the Setup program is complete, click Finish.

reating the RightFax Printer
After you have installed the Outbound module on the FileNet Print 
server, you must create a RightFax fax printer. Documents printed 
to this printer will be routed to the RightFax server for transmission.

Creating the RightFax printer requires these basic steps:

1. Create the RightFax printer on the FileNet product suite server 
(described on page 26).

2. Configure the RightFax print queue on the Print server 
(described on page 27).

Creating the Right
server

Important  These i
you are creating a R
want to review these
RightFax printer in y

1. On the Image S
Editor by select
Configuration 
Configuration 

2. Enter the datab
server to config
selected, and c
Configuration E

3. Click the Proce

4. Select Add a P
dialog box open

5. Select WorkFlo
Next.

6. Type a name fo

You cannot incl
underscores or
(for example, R

7. Enter the IP add
Next.

8. Select the pape

9. Select the fax re

10.Specify if you w
then click Next

11.When you see 
successfully,” cl
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ver, select Start > Programs > FileNET 
e Control. The FileNet Print Service 
ns.

int Service Control Dialog Box
Chapter 3 Using the Ou

2.To confirm the new printer has been successfully added, click 
the Printing tab. The new printer should appear in the list of 
available printers.

3.Close the FileNet IMS System Configuration Editor. Click Yes 
when you are prompted to save the changes.

4.Restart the Image Services server.

figuring the RightFax print queue on the FileNet Print 
er
his step configures the RightFax print queue on the FileNet Print 
erver to communicate with the RightFax server. All documents 
ent to the RightFax server via this RightFax print queue will be 
ssociated with a single RightFax user ID. The properties and 
ermissions of this user ID will be used for all outbound faxes sent 

rom the Image Services repository. Although any existing user ID 
ill work for this purpose, you may want to create a special 
ightFax user ID dedicated to faxes originating from FileNet P8 
sers.

f a document is created with PostScript fonts, then it must be sent 
o the RightFax server from the FileNet Print server with the fonts. In 
his step, you will specify that fonts be downloaded with the 
ocument. 

1. On the FileNet Print ser
Print > FileNET Servic
Control dialog box ope

Figure 3.2  The FileNet Pr
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 RightFax print queue

figuration dialog box, under IDMIS Selection 
Image Services Selection (in Print 4.3), select 
e for the Print server you are configuring. The 
htFax printer you created on the Image Services 
in the FileNET Queues to Configure list.

tFax printer name and click Configure. The 
inter Configuration dialog box opens.

eneric Fax Printer Configuration Dialog Box

ame box, enter the name of the RightFax server.

ype box, select RightFax Server.

ame box, type the name of a RightFax user ID. 
ID on the RightFax server that all outbound faxes 
 to.
2. Click Configure, and the Print Configuration dialog box opens. 
Complete the following steps:

� Configure the RightFax print queue (described on page 28).

� Configure font downloading (described on page 29).

Figure 3.3  The Print Configuration Dialog Box

To configure the

1. In the Print Con
(in Print 4.2) or 
the domain nam
name of the Rig
server appears 

2. Select the Righ
Generic Fax Pr

Figure 3.4  The G

3. In the Server N

4. In the Server T

5. In the Logon N
This is the user 
will be assigned
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dministrator
 monitors the FileNet product suite 
quests for printers configured on the 

ministrator in FileNet Print 4.2
 Print Administrator is an application that 
 server and picks up print requests for 
Print server. FileNet Print Administrator 
e Print server in order to continually 
erver. After you start FileNet Print 
imized, but do not close the application.

nistrator, select Start > Programs > 
Applications > Panagon Print 

ministrator in FileNet Print 4.3
Net Print service is a Windows NT 
roduct suite server and picks up print 
ured on the Print server. The FileNet 
unning on the Print server in order to 
duct suite server.
Chapter 3 Using the Ou

. In the Password box, type the password for the RightFax user 
ID you entered in the Logon Name box.

. Under PostScript, verify that the Send “Exitserver” 
Commands check box is not selected. Click to clear the check 
box.

. Complete the remaining entries in this dialog box according to 
your requirements. When you are done, click OK. The Generic 
Fax Printer Configuration dialog box closes.

o download fonts

. In the Print Configuration dialog box, click Fonts. The Fonts 
and Character Sets dialog box opens.

Figure 3.5  The Fonts and Character Sets Dialog Box

. Under PostScript Printer Fonts, in the Automatically 
Download list, click Beginning of Each Job.

. Complete the remaining entries in this dialog box according to 
your requirements. When you are done, click OK. The Fonts 
and Character Sets dialog box closes.

Starting FileNet Print A
FileNet Print Administrator
server and picks up print re
Print server.

Starting FileNet Print Ad
In FileNet Print 4.2, FileNet
monitors the product suite
printers configured on the 
must remain running on th
monitor the product suite s
Administrator, it can be min

To start FileNet Print Admi
FileNET Panagon Server 
Administrator.

Starting FileNet Print Ad
In FileNet Print 4.3, the File
service that monitors the p
requests for printers config
Print service must remain r
continually monitor the pro
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S

x Manager in FileNet Print 4.3
 Manager in FileNet Print 4.3, select Start > 
ET Print > Fax Manager.

 RightFax from the IDM Viewer
 printer is created and properly configured, you 
axes from the IDM Viewer.

m the IDM Viewer

P8 client computer, run FileNet IDM Viewer.

from the data repository.

leNET Print/Fax. The FileNET Print/Fax dialog 

ting the RightFax Printer

x, select the name of your RightFax printer.
To start the FileNet Print service

1. Select Start > Programs > FileNET Print Service Control. 
The FileNet Print Service Control dialog box opens.

Figure 3.6  The FileNet Print Service Control Dialog Box

2. Click Start.

tarting FileNet Fax Manager
FileNet Fax Manager requests and processes fax addressing 
information for print jobs sent to fax printers. It must remain running 
on the Print server in order to process print jobs sent to fax printers. 
After you start FileNet Fax Manager, it can be minimized, but do not 
close the application.

Tip  The FileNet Fax Manager screen may need to refreshed in order to 
get the status of RightFax faxes from the RightFax server.

Starting FileNet Fax Manager in FileNet Print 4.2
To start FileNet Fax Manager in FileNet Print 4.2, select Start > 
Programs > FileNET Panagon Server Applications > Panagon 
Fax Manager.

Starting FileNet Fa
To start FileNet Fax
Programs > FileN

Sending a Fax via
Once the RightFax
are ready to send f

To send a fax fro

1. On any FileNet 

2. Load an image 

3. Select File > Fi
box opens.

Figure 3.7  Selec

4. In the Name bo
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Chapter 3 Using the Ou

. Click Properties. The FileNet Printer/Fax dialog box opens.

Figure 3.8  Entering Fax Addressing Information

. Under Fax Options, in the Phone number box, type the 
destination fax number. This is a required entry. All other entries 
are optional. The text you enter in the From, To, Subject, and 
Memo boxes will appear on the fax cover sheet.

If you enter a subject in the Subject box, it will appear in the 
Notes section of the RightFax cover sheet along with any text 
you enter in the Memo box.

. When you have completed the fax addressing information, click 
Save Print/Fax Settings.

. Click OK to send the fax.

� � �
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nel and double-click the RightFax EDC 
he Captaris EDC Configuration dialog 

 Configuration dialog box

omponents of the External Document 
 buttons on this dialog box. Click a 
ponent.

ption in the External Document 
n in the title bar and then click the 
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dix A

erstanding the External Document Connector

he External Document Connector is a component of the RightFax 
erver that monitors the server for fax documents to process and 
ass to the RightFax Connector for Capture Professional. The 
xternal Document Connector processes documents using a set of 
teps called a “DataFlow.” The DataFlow is comprised of several 
istinct processes called “FlowPoints.” Each FlowPoint monitors a 
pecific folder for fax documents, acts on the documents, and then 
asses them on to the next FlowPoint.

ng the External Document Connector 
uration Program
he External Document Connector configuration program is 

nstalled as an application in Windows Control Panel. It is installed 
s an optional component of the RightFax server installation 
described on page 7).

To run the External Docum
open Windows Control Pa
program icon. This opens t
box.

Figure 3.9  The Captaris EDC

Each of the configurable c
Connector are listed in the
button to configure the com

For a description of each o
Connector, click the [?] ico
option you want defined.
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U

figuration dialog box to open a list of 
+] next to each DataFlow to display its 

of DataFlows in the External Document Connector

 individual processes performed by the External 
tor that are required to process your jobs. 
s will have different sets of FlowPoints, with the 
h DataFlow has a [Begin] and [End] FlowPoint. 
l and final steps required by the External 
tor for all modules.

-specific FlowPoints can be configured by 
Point and clicking Configure FlowPoint. Each 
onds to a processor and has a unique set of 
ns. For a description of each option in the 
ration dialog boxes, click the [?] icon in the title 
the option you want defined.
System  Click this button to edit the event logging level of the 
External Document Connector, as well as specify the location of the 
key folders on the RightFax server if you are running the External 
Document Connector on a remote computer.

Modules  Click this button to add the optional modules (such as 
the Connector for FileNet P8) that are controlled by the External 
Document Connector.

Sources  Click this button to configure the data sources that the 
External Document Connector will monitor for jobs to process.

Processors  Click this button to configure the scan intervals and 
logging levels of individual processors and to pause processors 
managed by the External Document Connector.

DataFlows  Click this button to configure the DataFlows and 
individual FlowPoints that control the processing of jobs between 
the RightFax and the external data source.

nderstanding DataFlows and FlowPoints
A DataFlow is a set of individual FlowPoints. Each module that you 
have installed which is controlled by the External Document 
Connector has a DataFlow. Click the DataFlows button in the 

Captaris EDC Con
DataFlows. Click [
FlowPoints.

Figure 3.10  The list 

FlowPoints are the
Document Connec
Different DataFlow
exception that eac
These are the initia
Document Connec

Each of the module
selecting the Flow
FlowPoint corresp
configuration optio
FlowPoint Configu
bar and then click 
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ng the EDC Monitor
he External Document Connector includes a management tool 
alled the External Document Connector Monitor (EDC Monitor). 
se the EDC Monitor to monitor the status of the connectors and 
rocessors under the control of the EDC, add and delete 
rocessor services, and configure the EDC components.

aution  The EDC Monitor application does not display errors that 
ccur with individual processors. It will only report specific job files that 
ave encountered errors. To check for errors in the External Document 
onnector’s processors, you must review the Event Log.

o open the EDC Monitor, on the RightFax server where the 
xternal Document Connector is installed select Start > 
rograms > RightFax EDC Monitor. The EDC Monitor program 
indow opens.

Figure 3.11  The External Doc
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cessor Services
ment Connector EDC Manager component and 
 processors managed by the External Document 
alled as services on the computer running the 
t Connector. The External Document Connector 
 tool that can be used to view the status of these 
nd remove services.

tatus of the External Document Connector 
es

x server, select Start > Programs > Captaris 
his opens the External Document Connector 
d monitoring tool.

 Services. This opens the Services dialog box.

 Services Dialog Box

displays the status of the EDC Manager service 
 all of the processors) as well as the status of the 
ssors. You must have at least one RightFax EDC 
le service and one RightFax EDC Convert 
 running for the Connector for FileNet P8 to 
ents in your FileNet data repository.
Each of the External Document Connector components is 
displayed in a hierarchical tree in the left pane. The status of each 
component is displayed in the right pane. The following table 
defines each of the status columns in the right pane.

Monitoring the Pro
The External Docu
all of the individual
Connector are inst
External Documen
Monitor includes a
services and add a

To monitor the s
processor servic

1. On the RightFa
EDC Monitor. T
management an

2. Select Tools >

Figure 3.12  The

This dialog box 
(which controls
individual proce
Manager Modu
Module service
store fax docum

Table A1  EDC Monitor Status Definitions

Column 
heading Definition

Status The External Document Connector component’s 
status. Possible values are:

� Failed - The component has shut down.
� Hung - The component is no longer responding.
� Job Errors - Errors prevented the image from 

processing.
� OK - The image was processed successfully.

Processed The total number of fax images that have been 
processed by this component.

Pending The total number of jobs currently queued for 
processing by this component.

Errors The total number of processing errors that have 
been logged by this component.

Activity The current active state of the component. 
Possible values are:

� Idle - The component is currently inactive.
� Paused- The component has been paused. No 

jobs will be processed.
� Processing Job- The component is currently 

processing a job.
� Shut Down- The component service is currently 

stopped.
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 which you want to add the service and 
 opens the Add a Service dialog box.

ervice Dialog Box

 the type of service to add.

enter the user name and password of 
e service will use to start up. This user 
ll administrative privileges to the 
 in step 3.

rocessors to a remote computer and you 
C Manager has not been properly 
es to be installed,” or if the services fail to 
ction on adding processes to a remote 

ors to a remote computer

Connector processors, a remote 
to locate certain folders on the RightFax 
ors. You must enter the share names of 
Appendix 

To start or stop a service, select the service name and click 
Start Service or Stop Service. To start or stop all of the 
services, select the computer name at the top of the list and 
click Start All Services or Stop All Services.

ing and removing services

he most processor-intensive step when archiving RightFax fax 
ocuments in a FileNet data repository is the conversion from the 
ightFax proprietary document format to the single-page TIFF files 

equired by Capture Professional. This conversion is performed by 
he Convert processor. To increase the speed and efficiency of 
ocument conversion, you can install and run additional instances 
f this connector on one or more computers on your network. 
lthough the automatic printing performed by the Print processor is 

ess processor intensive than the Convert processor, you can install 
nd run multiple instances of this connector as well.

ou can run a maximum of 16 of each type of processor. These 
rocessors can be run on the same computer that runs the External 
ocument Connector (the RightFax server) or on remote 
omputers to take advantage of the additional processor power.

ote  Although it is possible to install and configure more than 16 of 
ach type of processor, only 16 of each will actually function at any given 
ime.

o add new instances of a processor

. Run the EDC Monitor and select Tools > Services to open the 
Services dialog box.

. If you want to add the service to a remote computer that is not 
listed, click Add Computer and specify the name of the remote 
computer.

3. Select the computer to
click Add Service. This

Figure 3.13  The Add a S

4. Under Services, select

5. Under Login Account, 
the user account that th
account should have fu
computer you selected

6. Click OK.

Note  If you are adding p
receive the message “ED
configured to allow servic
start, see the following se
computer.

If you are adding process

To run External Document 
computer must know how 
server used by the process
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ssors

onitor and select Tools > Services to open the 
 box.

ice name.

vice.

ce is stopped, click Remove Service.

� � �
these folders in the RightFax External Document Connector 
Manager Configuration before you will be able to run the processor 
on remote computers.

1. Run the EDC Monitor and select Tools > Configuration to 
open the Captaris EDC Configuration dialog box.

2. Click the System button. This opens the EDC System Settings 
dialog box.

Figure 3.14  Specifying the remote paths that let you add processes to 
remote computers

3. In the Root Directory box, enter the UNC path to the share 
name of the RightFax\EDC folder on the computer on which the 
External Document Connector is installed (the RightFax server). 

Example \\RFSERV\Program Files\RightFax\EDC

4. In the Shared Directory box, enter the UNC path to the share 
name of the RightFax\Shared Files folder on the computer on 
which the External Document Connector is installed (the 
RightFax server). 

Example \\RFSERV\Program Files\RightFax\Shared Files

To remove proce

1. Run the EDC M
Services dialog

2. Select the serv

3. Click Stop Ser

4. When the servi
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htFax server.

x where the fax was received. This data is 
t.

 the recipient fax machine.

ceived. The date is stored in the format 
dix B

tFax Document Data Fields

he following table lists the data fields that are included with each 
ightFax fax document that can be used to index fax documents 

hat have been archived in an Image Services repository.

The data field column lists each RightFax document data field. 
On the Image Services server, the corresponding index fields are 
not required to use field names that are identical to these.
The field type and maximum length are needed when you 
configure data fields in the FileNet Image Services system. 

The fax type indicates whether the data is included with sent or 
received faxes. Some data is included with sent faxes only, some 
data is included with received faxes only, and some data is 
included with both sent and received faxes.

able B1  RightFax Document Data Fields

Data field
Field
type Max. length Fax type Description

BillingInfo1 String 15 Sent Billing code 1, if defined on the Rig

BillingInfo2 String 15 Sent Billing code 2, if defined on the Rig

CallerID String 21 Received The RightFax user ID of the mailbo
available if the fax board supports i

Caller Station ID String 21 Received The caller subscriber ID (CSID) of

Date Date N/A Sent/Received The date that the fax was sent or re
YYYY/MM/DD.
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fax was sent or received. The data is stored in the 
:MM:SS.

 the ANI routing data for the RightFax user who 
 on the RightFax server).

 key attributes of the fax in the format 
ttribute, ...)”. Available attributes are:

 RightFax server on which the fax was received.

server where the fax was received.

er’s organization.

nder’s organization.

number.

e number.

 by the RightFax External Document Connector 
ightFax Connector for FileNet P8.

 in the fax (including the cover page).
DateTime Special N/A Sent/Received The date and time that the 
format YYYY/MM/DD HH

DID/DTMF/ANI String 21 Received The DID or DTMF code or
received the fax (if defined

FaxAttributes String Variable Sent/Received A custom string displaying
“FaxAttributes (Attribute, A

� Broadcast
� Gateway
� Production
� InternetLink
� WinFax

Fax Channel Integer N/A Received The channel number on the

Fax Server String 31 Received The name of the RightFax 

FromCompanyFaxNumber String 31 Sent The fax number of the send

FromCompanyVoiceNumber String 31 Sent The voice number of the se

FromFaxNumber String 31 Sent The sender’s personal fax 

FromName String 99 Sent The sender’s name.

FromVoiceNumber String 31 Sent The sender’s personal voic

Job ID Unsigned long 15 Received The ID of the fax assigned
(EDC) component of the R

JobType String Variable Sent/Received The type of fax:

� Send
� Receive
� Print
� Unknown

NumberOfImages Integer N/A Sent/Received The total number of pages

Table B1  RightFax Document Data Fields (Continued)

Data field
Field
type Max. length Fax type Description
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st fax page is page 1. For sent faxes, the 
e number 0.

 The format of the date and time is based 

received. The data is stored in the format 
me is stored in 24-hour format.

 the remote fax machine.

 transmit the fax.

ceived. The time is stored in 24-hour 

nt.

ation.

s or error).

e).

y the RightFax server.

 of the sender. 

er ID of the recipient.

T
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PageNum Integer N/A Sent/Received The page number of the fax. The fir
cover page (if any) is assigned pag

Receive Time COleDateTime N/A Received The time that the fax was received.
on the local machine settings.

Receive Time String String N/A Received The date and time that the fax was 
MM/DD/YYYY HH:MM:SS. The ti

RemoteCSID String 21 Sent/Received The caller subscriber ID (CSID) of

SendDuration Integer N/A Sent/Received The number of seconds required to

Time Special N/A Sent/Received The time that the fax was sent or re
format as HH:MM:SS.

ToCityState String 59 Sent The city and state of the fax recipie

ToCompany String 59 Sent The name of the recipient’s organiz

ToFaxNumber String 31 Sent The destination fax number.

ToName String 59 Sent The fax recipient’s name.

ToVoiceNumber String 31 Sent The fax recipient’s voice number.

Transmission Status String 35 Received Status of the transmission (succes

Transmission Type Integer
enumerated

5 Received Fax image resolution (normal or fin

UniqueID String 15 Sent/Received The unique ID of the fax assigned b

UserID String 21 Sent/Received For sent faxes, the RightFax user ID

For received faxes, the RightFax us

able B1  RightFax Document Data Fields (Continued)

Data field
Field
type Max. length Fax type Description
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A
activate EDC 8-9
add services 37-38
archiving faxes

described 6
enabling by user 9

C
capture path 18-19
Capture Professional

See also Connector for Capture 
Professional

capture path 18-19
configuring 19-20
configuring batches 13-14
importing documents with filters 14
processing mode 13
settings collection 19-20
support for Fax Entry 17
templates 20
versions supported 6

configure
Capture Professional 19-20
Connector for Capture 

Professional 13-16
EDC 9-12

RightFax users 8-9
Connector for Capture Professional

configuring 13-16

D
data fields in RightFax documents 39-41

7-12
activating 8-9
adding services 37-38
configuring 9-12

DC Monitor 35-38
ilter configuration 10-11
nstalling 7

onitoring services 36-37
rint configuration 9-10
emoving services 38
ightFax user permissions 8-9
ample faxes 11-12
 Monitor
unning 35
tatus fields overview 36
sive filtering 15
nal Document Connector  See EDC

ntry support 17
dexing 20-21

Fax Manager, FileNet 30
Fax Manager, starting 30
faxes

ata fields 39-41

Index
d

-16

configuring batches 13-14
importing documents with filters 14-16
installing 12
overview 12

Connector for FileNet P8
Connector module 5
installation steps 7
Outbound module 25
overview 5-6

Connector module
See also Outbound module
components 5-6
installation overview 6
installation steps 7
overview 5-6

cooperative filtering 15
create RightFax printer 26-27

E
f
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EDC
r
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exclu
Exter

F
Fax E
fax in
configure (continued)
RightFax print queue 27-29
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EDC
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F

F
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G
g

I
IDM Viewer 30-31
i

i

i

K
k

M
m
m

product suites 17

R

sending a fax 30-31

sending faxes 25
services

See also Convert processor and Print 
processor

adding 37-38
remote 37
removing 37-38

settings collection, creating 19-20
start

FileNet Fax Manager 30
FileNet Print Administrator 29-30

supported FileNet product suites 17

T
templates in Capture Professional 20
nbound faxes, moving to the repository  See 
Connector module

ndexing faxes
enabling 20-21
mapping RightFax data 21-23

nstall
Connector for Capture Professional 12
EDC 7
Outbound module 25-26
overview 6

eywords, filter 16

apping RightFax index data 21-23
onitor services 36-37

remote services 37
remove services 38
RightFax

activate EDC 8
document data fields 39-41
External Document Connector  See EDC
print queue 27-29
printer, creating 26-27
sending a fax from the IDM Viewer 30-31
server version, required 6
user permissions 8-9

RightFax Connector for FileNet P8  See 
Connector for FileNet P8

RightFax.ocx file, installing 12

S
sample faxes 11-12
axes (continued)
indexing 21-23
sending from the IDM Viewer 25, 30-31

ileNet
Fax Manager, starting 30

ileNet Capture Professional  See Capture 
Professional

ileNet Print Administrator, starting 29
ilter configuration 10-11
ilter keywords 16
iltering documents in batches 14-16
onts, downloading 29

enerate sample faxes 11-12

O
Outbound module

installing 25-26
overview 25

P
path, capture 18-19
permissions, RightFax user 8-9
Print Administrator, FileNet 29
Print Administrator, starting 29-30
print configuration 9-10
print queue, RightFax 27-29
printer, RightFax 26-29
processing mode 13
processors  See services


	Contents
	Installing the RightFax Connector for FileNet P8
	Overview of the RightFax Connector for FileNet P8
	Understanding the Connector Module
	Installation Overview
	Installing the Connector on the RightFax Server
	Activating and Configuring the External Document Connector
	Installing the RightFax Connector on a Capture Professional WorkStation

	Configuring Capture Professional to Commit Documents to FileNet Data Repositories
	Supported FileNet Product Suites
	Support for the Capture Professional Fax Entry Feature
	Creating a Capture Path to Move Fax Documents into the Repository
	Configuring Capture Professional to Work with the RightFax Connector
	Enabling Fax Document Indexing in a FileNet Product Suite

	Using the Outbound Module to Send FileNet Documents as Faxes
	Installing and Configuring the Outbound Module
	Installing the Outbound Module on the FileNet Print Server
	Creating the RightFax Printer
	Starting FileNet Print Administrator
	Starting FileNet Fax Manager
	Sending a Fax via RightFax from the IDM Viewer

	Understanding the External Document Connector
	Running the External Document Connector Configuration Program
	Understanding DataFlows and FlowPoints
	Running the EDC Monitor

	RightFax Document Data Fields
	Index

